Fiber cut affecting primary I2 and NYC connections

Incident Report for SU ITS

Resolved

Overnight the fiber cut was repaired and connectivity has returned to normal.
Posted Aug 24, 2026 - 08:28 EDT

Identified

ITS has identified a network issue affecting primary connections. Our vendors are working on a repair. We will post an update as more information becomes available.
Posted Aug 23, 2026 - 21:52 EDT
This incident affected: Network Services (Internet).