OrangeNow mobile application is currently experiencing connectivity issues

Incident Report for SU ITS

Resolved

The vendor has corrected an issue within their caching layer and the issue is resolved.
Posted Aug 24, 2026 - 11:14 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 10:57 EDT

Investigating

ITS is investigating the issue and working with the vendor on a resolution.
Posted Aug 24, 2026 - 10:04 EDT
This incident affected: Campus Essentials (OrangeNow).