Widespread sporadic network issues

Incident Report for SU ITS

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 11:57 EDT

Investigating

We are currently investigating this issue.
Posted Aug 31, 2026 - 10:22 EDT
This incident affected: Network Services (Wired Network, Wi-Fi) and Communication & Collaboration (VoIP Campus Phones).