Power Disruption on Main Campus

Incident Report for SU ITS

Resolved

National Grid has restored power to all buildings.
Posted Sep 03, 2026 - 18:56 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 03, 2026 - 16:22 EDT

Monitoring

We are waiting for updates from National Grid.
Posted Sep 03, 2026 - 16:20 EDT

Update

We are continuing to investigate this issue.
Posted Sep 03, 2026 - 16:00 EDT

Investigating

At roughly 3:35 PM today, a power outage hit a number of buildings including:

106 Walnut
111 Waverly
200 Walnut Pl
206 Walnut
210 Walnut
300 Waverly
310 Walnut
Catholic Center
College of Professional Studies (Formerly UC)
Marshall Square Mall
Milton Hall
Riley Hall
Steam Station
University Ave Garage
West Campus Retail
Whitman School of Management

The situation for each building relating to the network, and the duration of the outage remains to be seen. Other buildings may also be impacted that we don't yet know about.

National Grid is looking into it, more to follow.
Posted Sep 03, 2026 - 15:53 EDT
This incident affected: Network Services (Wired Network, Wi-Fi, JMA Wireless).