According to Atlassian the issue is resolved for newly created notifications, and service is operating normally.
Older notifications are still being processed and we expect that to finish by the end of the day. As that backlog clears you may see a burst of delayed emails, including notifications for tickets that have already been updated or closed. Those are catching up, not new activity, and in most cases no action is needed.
Posted Aug 25, 2026 - 08:24 EDT
Identified
Atlassian has acknowledged an issue on their end. Our support case with Atlassian has been escalated into the engineering team.
Posted Aug 24, 2026 - 08:29 EDT
Investigating
We're seeing delays in Orange Tracker email notifications. Only the email alerts are affected. Tickets, comments, and updates are recording normally, and the Orange Tracker website and mobile app are working fine. ITS is investigating the issue with Atlassian support and will update when it's resolved.
Posted Aug 23, 2026 - 12:13 EDT
This incident affected: Campus Essentials (Orange Tracker).