Off-Campus access to printing.syr.edu (Papercut) disabled

Incident Report for SU ITS

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 17:36 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 27, 2026 - 15:26 EDT

Identified

There is currently an issue affecting the ability to access https://printing.syr.edu from off-campus. Users can still print on campus, using email to print, or mobility print.
Posted Aug 27, 2026 - 15:25 EDT
This incident affected: Identity, Security & Device Management (Papercut).